Encontro GeneXus GX29: o evento de tecnologia e negócios mais importante da América-Latina.

Atualizações em Java que impactarão GeneXus 16: Java 8 será a versão mínima de Java suportada pelos aplicativos gerados com a nossa plataforma

A partir da versão GeneXus 16 Upgrade 6 (a ser lançada em outubro de 2019) - e por questões de segurança dos aplicativos Java - as versões de Java que iremos suportar serão do Java 8.

No mundo Java, também tiveram avanços tecnológicos e atualizações que corrigem aspectos de segurança.
Nas diferentes versões de Java, houve avanços e atualizações tecnológicas, tanto no nível da linguagem quanto no nível do compilador. Os aspectos de segurança também foram aprimorados, e isso levou ao fato de que - muitas vezes - muitas bibliotecas exigem versões avançadas de Java Runtime Environment (JRE).
Em GeneXus, os esforços têm sido feitos para que as aplicações geradas possam executar tanto em versões legadas de JRE como em novas versões, mantendo a compatibilidade possível com código condicional e as opções de deployment que carregam uma ou outras bibliotecas segundo o ambiente de execução .
No entanto, manter esse esquema não é mais possível e pode até comprometer a segurança dos aplicativos gerados. É por isso que GeneXus 16 upgrade 5 já não suportará Java Development Kit (JDK) 1.6 para compilar soluções nem em JRE 1.6 para executá-los, a fim de acompanhar os avanços tecnológicos e requisitos de segurança das soluções geradas.
Observe que a versão 6 do Java, parou de ter suporte também da Oracle, há algum tempo. 
De qualquer forma, GeneXus recomenda atualizar as versões de Java de acordo com o recomendado pelos seu fabricantes, o fator de não usar as versões mais recentes de Java podem não estar disponíveis algumas funcionalidades nas aplicações geradas, como se vê neste artigo da Comunidade Wiki que fala sobre os requisitos de execução das aplicações geradas por GeneXus Java gerador
https://wiki.genexus.com/commwiki/servlet/wiki?30900,GeneXus+16+hardware+and+software+requirements,#Execution+requirements%3A